It is currently September 21st, 2017, 2:11 pm


Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: October 17th, 2014, 8:14 am 
User avatar

Site Admin
Joined: May 5th, 2013, 5:34 am
Posts: 568
Offline

Version 3.9.0 is now available on Curse and WoWInterface.
Finally it is here, the 6.0 Release version which has been delayed twice now. I would like to thank everyone who has submitted bug reports or weird behaviors happening so we could get them all (or at least most of them) before the release. We may do another release in a week or two to round up any new bugs that shows up or if we finally manage to nail down the currently known issues.

On another note, I wanted to keep this for when I finally launch V4, but due to my financial situation not improving (In fact, the horizon looks grim), I decided to open a Patreon account, this allows supporting members of the community to donate on a monthly basis to sustain me which in turn would let me devote even more time to LUI and start video series on it and such. I extremely appreciate everyone's donations, you guys have made it much easier for me to keep working on LUI. Not having access to Warlords content would have been a serious detriment to the cause.
A note I want to add before anyone jumps to conclusion: I do not intend to offer any rewards that could negatively affect users that cannot or will not donate or "pay" for features. I am not interested in a donor-only support forum that get better service, or donor-only special editions of LUI with more features. While they may receive some perks for donating (as mentioned on the Patreon page), I hope people that will donate will do so to show their support for me and my projects and NOT as a way to pay to get a better service.

I would like to also mention that V4 is coming along quite nicely. It may be early to pronounce but I have met someone that could breath some fresh life into the LUI textures and we might have updates here and there to prevent V4 to look exactly like V3 "but with better code". With this release out of the way I can again spend some time on it to get it fleshed out for a beta by Warlord's release. Don't quote me on that though.

Changelogs between versions encompass all changes between 3.8.3 and 3.9.0 some of which you may be familiar with if you have been using alpha versions. (6.0 alphas have been out since the day it launched)

Changelog:
- Updated for 6.0
- Core: Updated various frames to work with the new WoD changes.
- Bags: Add support for the new Reagents bank.
- Bags: Updated the New Item notification. Note that you will need to enable it in the Bags options.
- Bags: As quest items shouldn't be in your bags anymore, removed the option to highlight quest items.
- Infotext: Fix an issue not being able to invite connected realm guild members while using the "Hide Realm Name" option.
- Infotext: Add support for Heroes of the Storm in Friends display.
- Micromenu: Updated frame names due to WoD changes.
- Minimap: Changed the Objective Track offset to prevent the new art from overlapping with the sidebar textures.
- Tooltip: Tooltips in the friend list are now skinned to look like other tooltips found in LUI.
- Tooltip: Fixed an issue where the border colors wouldn't update when going from a player to another player next to each other.
- Tooltip: Fixed an issue where "Show For Abilities in Combat" could cause your skill tooltips to vanish regardless of combat state.
- Unitframes: Updated oUF framework to latest version 1.6.8
- Unitframes: Fixed issues with the new Eclipse Bar.
- VengeanceBar: Renamed to Resolve Bar. Max value may be wrong as we do more research on how it is handled mechanically.
- WorldMap: Updated for the WoD changes. Removed our instance maps options for the time being.

Known Issues:
- Female Human portrait in the unitframes shows the full model instead of a portrait.
- World Map player arrow sometimes goes missing if the Minimap is maximized.
Top
 Profile  
 
PostPosted: October 17th, 2014, 9:15 am 
Joined: October 17th, 2014, 9:12 am
Posts: 10
Offline

The Downloadlink on http://www.wowinterface.com/downloads/info14130-LUIv3.html didn't work.
Top
 Profile  
 
PostPosted: October 17th, 2014, 4:27 pm 
User avatar

Site Admin
Joined: May 5th, 2013, 5:34 am
Posts: 568
Offline

It might have still been pending when I posted this, that is fixed now.
Top
 Profile  
 
PostPosted: October 18th, 2014, 7:54 pm 
Joined: October 17th, 2014, 9:12 am
Posts: 10
Offline

ok works fine!

Only one thing:

In this Package you included the ForteXcorsist Fan Update from Alae:
http://www.wowinterface.com/downloads/info22684-ForteXorcistAlaesFanUpdate.html
In Version 1.985

I found this (Addon Version 1.993):
http://www.aleaaddons.ru/p/fortexorcist.html

Under the listed Forum Link on wowinterfaces.com to:
http://howtopriest.com/viewtopic.php?f=26&t=3177&start=140

This Version fixes some localization errors :)
Specially that in 1.985 no Druid spells work anymore..

You should update this in the Package i think.
Top
 Profile  
 
PostPosted: October 18th, 2014, 8:14 pm 
User avatar

Site Admin
Joined: May 5th, 2013, 5:34 am
Posts: 568
Offline

The version found in the package is version 1.992 found at: http://www.aleaaddons.ru/p/fortexorcist.html
I see they released a new version since.

I even leveled a druid up to ~15 without any errors while using it so I thought all the druid spell localization errors were fixed with that version.

I'll update it to whatever the latest version is in the next package, which should be released sometime next week after we fixed some of the other known issues we currently have.
Top
 Profile  
 
PostPosted: October 20th, 2014, 3:48 am 
Joined: October 17th, 2014, 9:12 am
Posts: 10
Offline

Ok then it was probably my fault ... Maybe I've taken the wrong version, as the download of the package did not work. I had actually looked extra again if another version is in there ... After I created my own package ... but then my matrix has indicated crap.. sorry.. with 1.985 Druid spells didn't work..
Top
 Profile  
 
PostPosted: October 22nd, 2014, 9:16 am 
Joined: October 17th, 2014, 9:12 am
Posts: 10
Offline

I have a question ... how do I fix such a problem:
On all characters LUI works perfectly so far ...
Only on a single character's it is not working properly ..
This character's has a name with a ì
This Characktername I have forgiven on multiple servers ..
Every time I turn off the game then I have to reinstall LUI on this character ..
However, the installation screen appears again and again and does not go away after clicking on Install..
Only when I delete the folder with the character name in the WTF directory, I can then install LUI normal for this character ...
If I log out and stay in the character's selection and log back in, its all ok ..
But if I turn off the game, and go back in... the Problem begins again..

What can i do ? how can i reset all informations of this character and beginn a complete new installation for him...
because after deleting the folder in WTF there are still some configs i see... that should be not there...


P.S even deleting all information of the multiple Characternames in the LUI config file did not fix it...
For this i used Sublime Text 3 as Editor and Code Folding so i have a wrap around the specific char infos...
also i delete the left infos by searching for the name...
Top
 Profile  
 
PostPosted: October 22nd, 2014, 10:00 am 
User avatar

Joined: May 5th, 2013, 8:57 am
Posts: 698
Offline

Dionysos wrote:
This character's has a name with a ì

And I bet you use a Mac too.

Refer: viewtopic.php?f=10&t=507
And: http://us.battle.net/wow/en/forum/topic/14880818884

We believe it's a bug with the WoW client and only Blizzard can fix it permanently. We can work around it and the first linked thread has a version with the fix in it that we'd love somebody to test.
Top
 Profile  
 
PostPosted: October 22nd, 2014, 11:35 am 
Joined: October 17th, 2014, 9:12 am
Posts: 10
Offline

Yes exactly, I use a Mac :)

I will test your fix as soon as possible ...

But in many forum contributions was something of / reload and Install Butoon appeared. The problem I have not .... only after a complete logout
Top
 Profile  
 
PostPosted: October 22nd, 2014, 12:36 pm 
Joined: October 17th, 2014, 9:12 am
Posts: 10
Offline

So it worked, in fact, after installing the fix indeed appeared once the Install screen, but then even after I made ​​the game out'm not ... completely ... but does the login after the character felt now more ..
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB® Forum Software © phpBB Group